112

Tôi thực sự muốn có được ở trên tất cả các sự tốt lành đầy màu sắc của colorscheme solarized , nhưng tôi dường như không thể có được nó cấu hình vừa phải.
Tôi có tệp năng lượng mặt trời chính trong thư mục .vim / colors của mình, tôi đã đặt màu hồ sơ thiết bị đầu cuối của mình thành những gì được liệt kê trên trang web và tôi đã thêm các dòng

 set background=dark
 let g:solarized_termcolors=16
 colorscheme solarized

với .vimrc của tôi, nhưng vim trông có màu xám và đang sử dụng màu xanh lá cây tươi sáng làm mặc định. Có ý kiến ​​gì không?

|
149

Đây là đề xuất của tôi cho những thứ cần thử:

  1. đảm bảo syntax onlà trong .vimrc của bạn
  2. Kiểm tra những gì t_Co vim đã chọn từ trình giả lập thuật ngữ của bạn (một cách nhanh chóng :echo &t_Co). Nếu đó là 8 bạn sẽ muốn se t_Co=16. Bạn cũng có thể thử se t_Co=256mặc dù không có let g:solarized_termcolors=16điều này sẽ sử dụng chế độ dự phòng 256, không hoàn toàn là bảng màu chính xác.

Tôi muốn bình luận về câu hỏi trên cho những điều sau đây, nhưng nghiệp 50 là bắt buộc. Vui lòng gửi email cho tôi qua trang web của dự án để khắc phục sự cố này vì tôi đang trong quá trình thiết lập một hướng đi tốt cho các vấn đề màu phổ biến.

|
  • 1

    Holy crap, không mong đợi một câu trả lời từ tác giả! Cảm ơn sự thay đổi, tôi sẽ thử các đề xuất của bạn và gửi email cho bạn sau hôm nay.

    – Hoàng Hồng Ngân 12:59:39 06/04/2011
  • 1

    T_Co cũng là vấn đề trên hộp Ubuntu của tôi. Tôi đã cài đặt gói gnome-terminal-colors-solarized, nhưng nó không sử dụng đúng màu nền. se t_Co = 16 đã lừa Cảm ơn!

    – Ngô Thuận Phương 16:16:52 19/05/2011
  • 1

    trật tự rõ ràng là vấn đề là tốt. tôi thấy rằng thiết lập t_Co = 16 sau khi màu sắc mặt trời không hoạt động. bạn phải đặt t_Co trước màu sắc.

    – Hồ Nhật Dũng 18:48:12 03/01/2012
  • 1

    Tôi thấy các dòng trống / trống của tôi không cùng màu nền. Làm thế nào để tôi sửa lỗi này?

    – startup android 22:21:32 17/04/2013
  • 1

    Tôi làm syntax on, let g:solarized_termcolors=256, set background=darkcolorscheme solarizednhưng nó không hoàn toàn chính xác. Ngoài ra tôi sử dụng mầm bệnh.

    – Dương Thúy Vi 08:37:33 11/04/2017
40

set t_Co=16let g:solarized_termcolors=16đã không làm việc cho tôi. Đây là những gì đã làm việc:

syntax on
let g:solarized_termcolors=256
set t_Co=256 
set background=dark
colorscheme solarized

Tôi hi vọng điêu nay se giup được ai đo.

|
19

Tôi phát hiện ra làm thế nào để làm điều đó từ này bài viết.

Tôi đã viết kịch bản sau đây để làm công cụ gnome-terminal.

gconftool-2 --set "/apps/gnome-terminal/profiles/Default/use_theme_background" --type bool false
gconftool-2 --set "/apps/gnome-terminal/profiles/Default/use_theme_colors" --type bool false
gconftool-2 --set "/apps/gnome-terminal/profiles/Default/palette" --type string "#070736364242:#D3D301010202:#858599990000:#B5B589890000:#26268B8BD2D2:#D3D336368282:#2A2AA1A19898:#EEEEE8E8D5D5:#00002B2B3636:#CBCB4B4B1616:#58586E6E7575:#65657B7B8383:#838394949696:#6C6C7171C4C4:#9393A1A1A1A1:#FDFDF6F6E3E3"
gconftool-2 --set "/apps/gnome-terminal/profiles/Default/background_color" --type string "#00002B2B3636"
gconftool-2 --set "/apps/gnome-terminal/profiles/Default/foreground_color" --type string "#838394949696"
|
  • 1

    Tôi nghĩ màu nền trước trên nền tối phải là "base0" chứ không phải "base00". Vì vậy, dòng cuối cùng nên làgconftool-2 --set "/apps/gnome-terminal/profiles/Default/foreground_color" --type string "#838394949696"

    – Võ Hồng Ngân 16:09:28 30/11/2011
  • 1

    Ahh, bạn biết đấy, tôi luôn nghĩ rằng đó là tắt. Cảm ơn!

    – Tạ Nguyên Khang 14:33:18 07/12/2011
  • 1

    nó đã khắc phục sự cố nhưng làm rối tung màu sắc ban đầu của các tệp và thư mục .... tôi chỉ muốn sử dụng năng lượng mặt trời trong vim hoặc ít nhất là giữ phần nổi bật của các thư mục và tệp (tệp thực thi) bây giờ mọi thứ trông giống nhau..có cách giải quyết khác không?

    – Lý Trọng Hùng 09:47:41 17/10/2014
  • 1

    Bài viết bạn liên kết đến trong câu trả lời của bạn không còn nữa. Câu trả lời này bây giờ thiếu bối cảnh / giải thích cần thiết.

    – Hoàng Ngọc Hoàn 08:31:33 11/04/2017
9

Nếu bạn đang cố gắng sử dụng vim với năng lượng mặt trời bên trong tmux, đây là cách khắc phục cho vấn đề của bạn.

https://github.com/krisleech/vimfiles/wiki/Fix-solarized-theme-in-tmux

|
3

Đối với những người yêu thích sao chép và dán, đây là cách bạn cài đặt vim colorscheme mặt trời trên Ubuntu:

sudo apt-get install wget unzip curl
cd
wget http://ethanschoonover.com/solarized/files/solarized.zip
unzip solarized.zip
mkdir .vim
mkdir .vim/colors/
mv solarized/vim-colors-solarized/colors/solarized.vim ~/.vim/colors/
cp .vimrc .vimrc.old
echo "syntax enable" > .vimrc
echo "set background=dark" >> .vimrc
echo "colorscheme solarized" >> .vimrc
curl https://raw.github.com/seebi/dircolors-solarized/master/dircolors.256dark > ~/.dircolors
source .bashrc
rm -r solarized
rm solarized.zip

Và uy tín

|
3

Tự mình thử, nó dường như hoạt động tốt hơn mà không cần

let g:solarized_termcolors=16

Đặt nó thành 16, tôi có được màu xanh lá cây tươi sáng mà bạn dường như mô tả. Có thể thử để nó ở mặc định 256?

Tuy nhiên, điều này không bắt chước hoàn hảo màu sắc từ ảnh chụp màn hình (mặc dù phiên bản ánh sáng trông khá gần). Tôi chỉ nhận được màu sắc với ảnh chụp màn hình nếu tôi sử dụng gvim.

Tôi đã không sử dụng màu hồ sơ thiết bị đầu cuối được cung cấp, tuy nhiên, vì vậy bạn có thể nhận được một kết quả khác.

|
2

Điều này làm việc cho tôi cho exherbo

git clone https://github.com/sigurdga/gnome-terminal-colors-solarized
cd gnome-terminal-colors-solarized
sh install.sh -s dark -p <my_current_profile>

256 màu trong vim cũng có thể giúp

|
  • 1

    Đây là giải pháp duy nhất hiệu quả với tôi. Tôi đang sử dụng sơ đồ thiết bị đầu cuối Solarized Dark mà Ubuntu mang theo, và trong khi bản thân nó trông ổn trong vỏ, Vim trông giống như một mớ hỗn độn. Một số câu trả lời khác ở đây (điều chỉnh Vim config) đã giúp nó gần đúng, nhưng màu nền vẫn là đen hoặc xám, thay vì màu xanh lam mà nó được cho là. Cài đặt màu sắc thay thế gnome-terminal này đã sửa nó với cấu hình Vim mặc định của tôi.

    – Hoàng Gia Linh 15:07:55 23/08/2017
1

Từ README ( nhấn mạnh của tôi):

LƯU Ý QUAN TRỌNG CHO NGƯỜI DÙNG THỜI GIAN:

Nếu bạn định sử dụng Solarized trong chế độ Terminal (tức là không phải trong phiên bản GUI như gvim hoặc macvim), vui lòng xem xét việc đặt bảng màu của trình giả lập thiết bị đầu cuối của bạn thành bảng màu Solarized. Tôi đã bao gồm các bảng màu cho một số trình giả lập thiết bị đầu cuối phổ biến cũng như Xdefaults trong bản tải xuống Solarized chính thức có sẵn từ [Trang chủ Solarized]. Nếu bạn sử dụng Solarized mà không có các màu này, Solarized sẽ cần được yêu cầu làm giảm màu sắc của nó thành một bộ tương thích với bảng màu 256 giới hạn (trong khi sử dụng các giá trị màu 16 ansi của thiết bị đầu cuối, bạn có thể đặt các giá trị cụ thể, chính xác cho Solarized bảng màu).

Nếu bạn sử dụng màu thiết bị đầu cuối tùy chỉnh, solarized.vim sẽ hoạt động tốt cho bạn. Nếu bạn đang sử dụng trình giả lập thiết bị đầu cuối hỗ trợ 256 màu và không muốn sử dụng màu thiết bị đầu cuối Solarized tùy chỉnh, bạn sẽ cần sử dụng 256 màu bị xuống cấp. Để làm như vậy, chỉ cần thêm dòng sau trước khi các colorschem solarizeddòng:

let g:solarized_termcolors=256

Một lần nữa, tôi khuyên bạn chỉ nên thay đổi màu thiết bị đầu cuối của mình thành giá trị Solarized bằng tay hoặc thông qua một trong nhiều sơ đồ thiết bị đầu cuối có sẵn để nhập .

Điều làm việc với tôi trên Ubuntu 16.04 với ứng dụng Terminal đi kèm là chỉ cần chọn Solarized cho cả "Màu văn bản và Màu nền" (chọn sáng hoặc tối) và "Bảng màu" trong Terminal> Tùy chọn> Cấu hình> (chọn của bạn)> Chỉnh sửa> Màu sắc

Một số câu trả lời khác khuyên bạn nên chọn bảng màu 256, nhưng, như đã đề cập trong tài liệu, điều này mang lại cho bạn một bảng màu xuống cấp (và rõ ràng tệ hơn theo quan điểm của tôi).

|

Câu trả lời của bạn (> 20 ký tự)

Bằng cách click "Đăng trả lời", bạn đồng ý với Điều khoản dịch vụ, Chính sách bảo mật and Chính sách cookie của chúng tôi.

Không tìm thấy câu trả lời bạn tìm kiếm? Duyệt qua các câu hỏi được gắn thẻ hoặc hỏi câu hỏi của bạn.